[ovs-dev] [PATCH 15/16] pktbuf: Assign UINT16_MAX in place of -1, for clarity.

Ben Pfaff blp at nicira.com
Fri Feb 12 13:59:50 PST 2010


On Fri, Feb 12, 2010 at 04:39:55PM -0500, Jesse Gross wrote:
> > @@ -194,7 +194,7 @@ pktbuf_retrieve(struct pktbuf *pb, uint32_t id, struct
> > ofpbuf **bufferp,
> >         error = 0;
> >     }
> >     *bufferp = NULL;
> > -    *in_port = -1;
> > +    *in_port = UINT16_MAX;
> >     return error;
> >  }
> 
> 
>  In ofproto.c/add_flow() we assign -1 to in_port if we don't need to call
> pktbuf_retrieve().  We probably should update that for consistency.

That's only on the "next" branch, so I pushed that change to "next".




More information about the dev mailing list