[ovs-dev] [wdp] classifier: Fix classifier bugs.
blp at nicira.com
Thu Jul 22 13:32:45 PDT 2010
On Thu, Jul 22, 2010 at 12:49:23PM -0700, Jesse Gross wrote:
> On Thu, Jul 22, 2010 at 12:43 PM, Ben Pfaff <blp at nicira.com> wrote:
> > On Thu, Jul 22, 2010 at 12:40:52PM -0700, Jesse Gross wrote:
> > > On Wed, Jul 21, 2010 at 4:21 PM, Ben Pfaff <blp at nicira.com> wrote:
> > >
> > > > On Mon, Jul 12, 2010 at 04:57:34PM -0700, Jesse Gross wrote:
> > > > > [regarding flow_compare, flow_equal, flow_hash]
> > > > >
> > > > I did find a set of names that should make readers more likely to look
> > > > at what the functions actually rather than guessing.
> > > >
> > > > [flow_compare_mostly, flow_equal_mostly, flow_hash_mostly]
> > >
> > > Those names definitely do make me wonder what the functions actually do.
> > > What do you think of flow_hash_fields() or flow_hash_headers()?
> > I tend to think that a structure has fields (even though the technical C
> > name is "members") so flow_hash_fields() is imperfect.
> > The in_port member is not a header even though it's compared, so
> > flow_hash_headers() is imperfect also.
> > What do you think is the least bad name?
> Personally, I think flow_hash_headers() is the most descriptive. I realize
> that in_port is not a header but I tend to group it together with the actual
> headers, more so than wildcards or priority.
OK, I did s/mostly/headers/ and pushed it. Thank you for your review.
More information about the dev