[ovs-dev] [PATCH] datapath: Scope global symbols with ovs_ prefix.
shemminger at vyatta.com
Tue Nov 22 10:58:51 PST 2011
On Tue, 22 Nov 2011 10:34:04 -0800
Ben Pfaff <blp at nicira.com> wrote:
> On Tue, Nov 22, 2011 at 10:30:05AM -0800, Jesse Gross wrote:
> > OVS has quite a few global symbols that should be scoped with a
> > prefix to prevent collisions with other modules in the kernel.
> > Suggested-by: Stephen Hemminger <shemminger at vyatta.com>
> > Signed-off-by: Jesse Gross <jesse at nicira.com>
> Acked-by: Ben Pfaff <blp at nicira.com>
> I didn't apply or build this patch, so my ack is based on a visual
> skim only.
> We could rename some other identifiers too (e.g. sw_flow -> ovs_flow)
> but since they have internal linkage or no linkage it's not as
Only global symbols need it. You can keep shorter name on statics
More information about the dev