[ovs-dev] [PATCH v2] datapath: Refactor actions in terms of match fields.
blp at nicira.com
Wed Oct 19 16:04:32 PDT 2011
On Wed, Oct 19, 2011 at 04:03:41PM -0700, Pravin Shelar wrote:
> On Wed, Oct 19, 2011 at 2:07 PM, Ben Pfaff <blp at nicira.com> wrote:
> > Please don't give a function in ofproto-dpif.c a name beginning with
> > nl_, since that prefix belongs to lib/netlink.c. ?I think you can
> > rename nl_msg_put_nested_key() to put_nested_key(). ?Or it could
> > reasonably go in odp-util.c under some appropriate name. ?In fact, it
> > seems appropriate to me to put the bulk of the new code in the
> > commit_*() functions into odp-util.c; ofproto-dpif.c is already too
> > big and this seems like a clean separation.
> ok, next patch (related to SET_PRIORITY) that I am working on will
> make all commit_odp_ functions independent of ctx. Then I will move
> them to odp-utils.
That seems reasonable. Thank you.
More information about the dev