[ovs-dev] [PATCH] debian: Fix dependencies for openvswitch-datapath-dkms package.

Justin Pettit jpettit at nicira.com
Sat Feb 11 13:13:57 PST 2012


Seems reasonable to me. 

--Justin


On Feb 10, 2012, at 11:00 AM, Ben Pfaff <blp at nicira.com> wrote:

> The OVS kernel module, like other kernel modules, does not need a working
> userspace build environment, but the OVS "configure" script and makefiles
> don't support a kernel-only build, so "configure" fails if libc6-dev is
> not installed.
> 
> It would be better to change the "configure" script and makefiles to handle
> this special case, but that was more work than I initially expected it to
> be.
> 
> Bug #8606.
> Reported-by: Edwin Chiu <echiu at nicira.com>
> Signed-off-by: Ben Pfaff <blp at nicira.com>
> ---
> debian/control |    2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/debian/control b/debian/control
> index 4f71465..09a26b1 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -25,7 +25,7 @@ Description: Open vSwitch datapath module source - module-assistant version
> 
> Package: openvswitch-datapath-dkms
> Architecture: all
> -Depends: dkms (>= 1.95), make, ${misc:Depends}
> +Depends: dkms (>= 1.95), make, libc6-dev, ${misc:Depends}
> Description: Open vSwitch datapath module source - DKMS version
>  This package provides the Open vSwitch datapath module source code
>  that is needed by openvswitch-switch.  DKMS can built the kernel
> -- 
> 1.7.2.5
> 
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> http://openvswitch.org/mailman/listinfo/dev



More information about the dev mailing list