[ovs-discuss] Fwd: Assistance with setting-up Open vSwitch

Justin Pettit jpettit at nicira.com
Sat Dec 26 19:04:07 PST 2009


>    For both openssl and the kernel-headers, I have the same versions installed as the ones given by the two links below and I'm still getting the same errors. I read somewhere online that the second error (the one where the "build" folder does not exist) occurs because I have not built my kernel.  Is that possible?

Hi, Sydney.  I did a fresh install of Fedora 10 for x86-64 in a VM and was able to get a clean build.  There were a few errors when I built from the "citrix" branch.  If I build from the master branch, it all builds cleanly, though.  You can get a snapshot of the master branch by downloading from this link:

	http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=snapshot;sf=tgz

When I did the installation of Fedora, I indicated that I wanted to do software development, which included all the necessary headers and libraries.  I think you can do this after a standard installation by opening the "Add/Remove Software" program by following these menus in the UI:

	System->Administration->Add/Remove Software

Then, just make sure "Development Libraries" and "Development Tools" are selected from the "Package collections" in the upper-left corner..  I then just needed to run the following commands in the source directory:

	./boot.sh
	./configure --with-l26=/lib/modules/`uname -r`/build --enable-ssl=yes
	make

This all built cleanly and seems to work.  If you have any question, please don't hesitate to follow-up!

--Justin






More information about the discuss mailing list