[ovs-discuss] Bridge Compatible Mode: /sys/class/net/br0/bridge: No such file or directory

Shi Jin jinzishuai at gmail.com
Wed Jul 6 16:32:06 PDT 2011


Hi there,

I am trying to get open vswitch to work with libvirt/KVM on RHEL as part of
integration into OpenNebula.
I loaded Linux bridge compatible module and use "brctl adbr" to create
bridge devices.

However, I got some errors in "brctl show"

[root at node5 openvswitch]# brctl show
bridge name    bridge id        STP enabled    interfaces
br0        /sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
/sys/class/net/br0/bridge: No such file or directory
0000.0024e8561195    no        eth1


However, I am still able to use the br0 device for my libvirt template
and run KVM VM in RHEL-6.

Is there anything wrong or this is expected normal behavior.


Thanks.

Shi


-- 
Shi Jin, Ph.D.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/discuss/attachments/20110706/b657d59f/attachment.htm>


More information about the discuss mailing list