[ovs-discuss] Installation problem on Ubuntu Oneiric

胡靖飞 hujingfei914 at msn.com
Tue Feb 21 17:42:23 PST 2012


Hi, everyone,I have installed open vswitch according to INSTALL.Linux on Ubuntu Oneiric. And the open vswitch is in userspace. I have typed the commands in following steps:
       ovs-vsctl --no-wait init
       ovs-vswitchd --pidfile --detach --logfile
       ovs-vsctl add-br br0
       ovs-vsctl set bridge br0 datapath_type=netdev
       ovs-vsctl add-port br0 eth0
       ovs-vsctl add-port br0 eth1
       ovs-vsctl add-port br0 eth2
After that, I have checked the log file under /usr/local/var/log/openvswitch/ovs-vswitchd.log, got: 
Feb 22 09:29:53|00001|vlog|INFO|opened log file /usr/local/var/log/openvswitch/ovs-vswitchd.logFeb 22 09:29:53|00002|reconnect|INFO|unix:/usr/local/var/run/openvswitch/db.sock: connecting...Feb 22 09:29:53|00003|reconnect|INFO|unix:/usr/local/var/run/openvswitch/db.sock: connectedFeb 22 09:29:53|00004|bridge|INFO|created port eth1 on bridge br0Feb 22 09:29:53|00005|bridge|INFO|created port eth2 on bridge br0Feb 22 09:29:53|00006|bridge|INFO|created port eth0 on bridge br0Feb 22 09:29:53|00007|bridge|INFO|created port br0 on bridge br0Feb 22 09:29:53|00008|dpif_linux|ERR|Generic Netlink family 'ovs_datapath' does not exist. The Open vSwitch kernel module is probably not loaded.Feb 22 09:29:53|00009|dpif|WARN|failed to enumerate system datapaths: No such file or directoryFeb 22 09:29:53|00010|ofproto|INFO|using datapath ID 0000002320cc3203Feb 22 09:29:53|00011|netdev_linux|WARN|/sys/class/net/eth1/carrier: open failed: No such file or directoryFeb 22 09:29:53|00012|netdev|WARN|failed to get flags for network device eth1: No such deviceFeb 22 09:29:53|00013|bridge|WARN|could not open network device eth1 (No such device)Feb 22 09:29:53|00014|bridge|WARN|eth1 port has no interfaces, droppingFeb 22 09:29:53|00015|bridge|INFO|destroyed port eth1 on bridge br0Feb 22 09:29:53|00016|netdev_linux|WARN|br0: obtaining netdev stats via vport failed 2Feb 22 09:29:53|00017|netdev_linux|WARN|eth0: obtaining netdev stats via vport failed 2Feb 22 09:29:53|00018|netdev_linux|WARN|/sys/class/net/eth2/carrier: open failed: No such file or directoryFeb 22 09:29:53|00019|netdev|WARN|failed to get flags for network device eth2: No such deviceFeb 22 09:29:53|00020|bridge|WARN|could not open network device eth2 (No such device)Feb 22 09:29:53|00021|bridge|WARN|eth2 port has no interfaces, droppingFeb 22 09:29:53|00022|bridge|INFO|destroyed port eth2 on bridge br0Feb 22 09:29:53|00023|ofproto|INFO|datapath ID changed to 0000001eec968fb2
So it seems that I failed on this little attempt. Is there steps or requirements I have missed? I have installed all the softwares required for a userspace program of Open vSwitch. And how to run a simple demo with Open vSwitch?Hope make myself clear.
Cheer,
Hu Jingfei 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/discuss/attachments/20120222/e6be2f35/attachment.htm>


More information about the discuss mailing list