[ovs-discuss] [openflow-discuss] OFTest failure

Dan Talayco dtalayco at stanford.edu
Tue May 8 23:58:04 PDT 2012


Hey Sonny-- 

We haven't tested all versions of OVS yet.  It might be worth starting a wiki page to catalogue the results.

-Dan


On Tuesday, May 8, 2012 at 11:33 PM, sonny sonny wrote:

> 
> 
> ---------- Forwarded message ----------
> From: sonny sonny <sonny085 at gmail.com (mailto:sonny085 at gmail.com)>
> Date: Tue, May 8, 2012 at 8:54 PM
> Subject: Re: [openflow-discuss] OFTest failure
> To: Dan Talayco <dtalayco at stanford.edu (mailto:dtalayco at stanford.edu)>
> 
> 
> Hi Dan, 
>  
> 
> It is running on Ubuntu but not on fedora, I have tested this.
> 
> 
> On ubuntu following 3 test cases are failing on OVS 1.2.2, is this known issue of automation?
> 
> 
> Are these test cases pass at your end?
> 
> 
> 
> ====================================================================== 
> FAIL: runTest (pktact.AllExceptOneWildcardMatch)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
> 
> File "/home/varun/oftest/tests/pktact.py", line 685, in runTest
> flow_match_test(self, pa_port_map, wildcards=all_exp_one_wildcard)
> File "/home/varun/oftest/tests/testutils.py", line 497, in flow_match_test
> check_expire=check_expire)
> File "/home/varun/oftest/tests/testutils.py", line 460, in flow_match_test_port_pair
> receive_pkt_verify(parent, egr_port, exp_pkt)
> File "/home/varun/oftest/tests/testutils.py", line 256, in receive_pkt_verify
> "Did not receive packet port " + str(egr_port))
> File "/home/varun/oftest/tests/basic.py", line 106, in assertTrue
> unittest.TestCase.assertTrue(self, cond, msg)
> AssertionError: Did not receive packet port 2
> ======================================================================
> FAIL: runTest (pktact.ModifyTOS)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
> 
> File "/home/varun/oftest/tests/pktact.py", line 935, in runTest
> action_list=acts, max_test=2)
> File "/home/varun/oftest/tests/testutils.py", line 497, in flow_match_test
> check_expire=check_expire)
> File "/home/varun/oftest/tests/testutils.py", line 460, in flow_match_test_port_pair
> receive_pkt_verify(parent, egr_port, exp_pkt)
> File "/home/varun/oftest/tests/testutils.py", line 267, in receive_pkt_verify
> "Packet match error on port " + str(egr_port))
> AssertionError: Packet match error on port 2
> ======================================================================
> FAIL: runTest (pktact.SingleWildcardMatch)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
> 
> File "/home/varun/oftest/tests/pktact.py", line 659, in runTest
> flow_match_test(self, pa_port_map, wildcards=wc, max_test=10)
> File "/home/varun/oftest/tests/testutils.py", line 497, in flow_match_test
> check_expire=check_expire)
> File "/home/varun/oftest/tests/testutils.py", line 460, in flow_match_test_port_pair
> receive_pkt_verify(parent, egr_port, exp_pkt)
> File "/home/varun/oftest/tests/testutils.py", line 256, in receive_pkt_verify
> "Did not receive packet port " + str(egr_port))
> File "/home/varun/oftest/tests/basic.py", line 106, in assertTrue
> unittest.TestCase.assertTrue(self, cond, msg)
> AssertionError: Did not receive packet port 2
> --------------------------------------------------------------
> - 
> Sonny
> 
> On Tue, May 8, 2012 at 12:14 AM, Dan Talayco <dtalayco at stanford.edu (mailto:dtalayco at stanford.edu)> wrote:
> > I've run it on this.  We've run it on other Ubuntu versions as well. 
> > 
> > dtalayco at ub-dev-vm:~$ uname -a 
> > Linux ub-dev-vm 2.6.32-27-server #49-Ubuntu SMP Thu Dec 2 02:05:21 UTC 2010 x86_64 GNU/Linux
> > dtalayco at ub-dev-vm:~$ cat /etc/issue
> > Ubuntu 10.04.1 LTS \n \l
> > 
> > -Dan 
> > 
> > 
> > 
> > 
> > On Monday, May 7, 2012 at 4:21 AM, sonny sonny wrote:
> > 
> > > Hi Dan,
> > >  
> > > I have tried on 32 bit fedora 15 machine also, same issue is there.
> > > Re-use flag is present when running OFTest on 64 bit machine too.I do not think that there is platform issue.
> > >  
> > > Please confirm on which platform you are able to run OFTest with all modules in one go on OVS .
> > >  
> > > -Sonny
> > > 
> > > On Fri, May 4, 2012 at 10:04 PM, Dan Talayco <dtalayco at stanford.edu (mailto:dtalayco at stanford.edu)> wrote:
> > > > 
> > > > 
> > > > On Friday, May 4, 2012 at 4:31 AM, sonny sonny wrote:
> > > > 
> > > > > Hi,
> > > > > I have used below mentioned commands and now test cases are running,but module is always failing with "address is in use" error.
> > > > > Is that like every test case requires tcp port 6633 free? but how then a module will run in one go.Logs are attached with this mail. 
> > > > > I am running OFTest on 64 bit machine with Fedora 15, OVS is also on same machine, I hope there is no issue with platform dependency?
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > 
> > > > 
> > > > I hope not too, but it looks that way at this point.  I think there's a "reuse" flag that can be sent to sockets and maybe there are differences on platforms relative to that.
> > > > 
> > > > I'll see if anyone here is running on Fedora. 
> > > > 
> > > > -Dan 
> > > >  
> > > > > 
> > > > > 
> > > > >  ip link add type veth
> > > > >  ifconfig veth0 up
> > > > >  ifconfig veth1 up 
> > > > >  ip link add type veth
> > > > >  ifconfig veth2 up
> > > > >  ifconfig veth3 up 
> > > > >  ip link add type veth
> > > > >  ifconfig veth4 up
> > > > >  ifconfig veth5 up 
> > > > >  ip link add type veth
> > > > >  ifconfig veth6 up
> > > > >  ifconfig veth7 up 
> > > > >  ovsdb-server --remote=punix:/usr/local/var/run/openvswitch/db.sock --remote=db:Open_vSwitch,manager_options --private-key=db:SSL,private_key --
> > > > > certificate=db:SSL,certificate --bootstrap-ca-cert=db:SSL,ca_cert --pidfile --detach
> > > > > ovs-vsctl --no-wait init
> > > > > ovs-vswitchd --pidfile --detach
> > > > > ovs-vsctl  del-br br0
> > > > > ovs-vsctl  add-br br0
> > > > > ovs-vsctl  add-port br0 veth0
> > > > > ovs-vsctl  add-port br0 veth2
> > > > > ovs-vsctl  add-port br0 veth4
> > > > > ovs-vsctl  add-port br0 veth6
> > > > >  
> > > > > ovs-vsctl set-controller br0 tcp:127.0.0.1:6633 (http://127.0.0.1:6633/)
> > > > > ovs-vsctl set controller br0 max_backoff=1000 
> > > > >  ovs-ofctl show br0
> > > > > OFPT_FEATURES_REPLY (xid=0x1): ver:0x1, dpid:00002e29c590ac4b
> > > > > n_tables:1, n_buffers:256
> > > > > features: capabilities:0x87, actions:0xfff
> > > > >  1(veth0): addr:82:d2:54:d0:d0:42
> > > > >      config:     0
> > > > >      state:      0
> > > > >      current:    10GB-FD COPPER
> > > > >  2(veth2): addr:8e:5f:5f:26:3d:1e
> > > > >      config:     0
> > > > >      state:      0
> > > > >      current:    10GB-FD COPPER
> > > > >  3(veth4): addr:a2:63:82:a3:8f:9f
> > > > >      config:     0
> > > > >      state:      0
> > > > >      current:    10GB-FD COPPER
> > > > >  4(veth6): addr:32:5c:b6:b1:7d:27
> > > > >      config:     0
> > > > >      state:      0
> > > > >      current:    10GB-FD COPPER
> > > > >  LOCAL(br0): addr:2e:29:c5:90:ac:4b
> > > > >      config:     0
> > > > >      state:      0
> > > > > OFPT_GET_CONFIG_REPLY (xid=0x3): frags=normal miss_send_len=0
> > > > >  
> > > > > sudo ./oft --verbose --test-spec=Echo
> > > > > WARNING: No route found for IPv6 destination :: (no default route?)
> > > > > runTest (basic.Echo) ... ok 
> > > > > ----------------------------------------------------------------------
> > > > > Ran 1 test in 0.266s 
> > > > > OK
> > > > > sudo ./oft --verbose --test-spec=PacketIn
> > > > > WARNING: No route found for IPv6 destination :: (no default route?)
> > > > > runTest (basic.PacketIn) ... ok 
> > > > > ----------------------------------------------------------------------
> > > > > Ran 1 test in 2.347s 
> > > > > OK
> > > > > sudo ./oft --verbose --test-spec=PacketOut
> > > > > WARNING: No route found for IPv6 destination :: (no default route?)
> > > > > runTest (basic.PacketOut) ... ok 
> > > > > ----------------------------------------------------------------------
> > > > > Ran 1 test in 1.786s 
> > > > > OK
> > > > > sudo ./oft --verbose --test-spec=All
> > > > > WARNING: No route found for IPv6 destination :: (no default route?)
> > > > > runTest (pktact.All) ... ok 
> > > > > ----------------------------------------------------------------------
> > > > > Ran 1 test in 8.799s 
> > > > > OK
> > > > > 
> > > > > sudo ./oft --verbose --test-spec=basic
> > > > > WARNING: No route found for IPv6 destination :: (no default route?)
> > > > > runTest (basic.DataPlaneOnly) ... ok
> > > > > runTest (basic.DescStatsGet) ... ok
> > > > > runTest (basic.Echo) ... Exception in thread Thread-6:
> > > > > Traceback (most recent call last):
> > > > >   File "/usr/lib64/python2.7/threading.py", line 530, in __bootstrap_inner
> > > > >     self.run()
> > > > >   File "/usr/lib/python2.7/site-packages/oftest-0.0.1-py2.7.egg/oftest/controller.py", line 389, in run
> > > > >     self.listen_socket.bind((self.host, self.port))
> > > > >   File "/usr/lib64/python2.7/socket.py", line 224, in meth
> > > > >     return getattr(self._sock,name)(*args)
> > > > > error: [Errno 98] Address already in use 
> > > > > Controller startup failed (no switch addr); exiting
> > > > >  
> > > > > ===================================================================================================================== 
> > > > > netstat -antup
> > > > > Active Internet connections (servers and established)
> > > > > Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
> > > > > tcp        0      0 0.0.0.0:111 (http://0.0.0.0:111/)                 0.0.0.0:*                   LISTEN      1010/rpcbind        
> > > > > tcp        0      0 0.0.0.0:54960 (http://0.0.0.0:54960/)               0.0.0.0:*                   LISTEN      1192/rpc.statd      
> > > > > tcp        0      0 192.168.122.1:53 (http://192.168.122.1:53/)            0.0.0.0:*                   LISTEN      1300/dnsmasq        
> > > > > tcp        0      0 0.0.0.0:22 (http://0.0.0.0:22/)                  0.0.0.0:*                   LISTEN      1238/sshd           
> > > > > tcp        0      0 127.0.0.1:631 (http://127.0.0.1:631/)               0.0.0.0:*                   LISTEN      1106/cupsd          
> > > > > tcp        0      0 127.0.0.1:25 (http://127.0.0.1:25/)                0.0.0.0:*                   LISTEN      1221/sendmail: acce 
> > > > > tcp        0      0 127.0.0.1:6633 (http://127.0.0.1:6633/)              127.0.0.1:46719 (http://127.0.0.1:46719/)             TIME_WAIT   -                   
> > > > > tcp        0      0 :::111                      :::*                        LISTEN      1010/rpcbind        
> > > > > tcp        0      0 :::22                       :::*                        LISTEN      1238/sshd           
> > > > > tcp        0      0 ::1:631                     :::*                        LISTEN      1106/cupsd          
> > > > > tcp        0      0 :::47482                    :::*                        LISTEN      1192/rpc.statd      
> > > > > udp        0      0 0.0.0.0:5353 (http://0.0.0.0:5353/)                0.0.0.0:*                               850/avahi-daemon: r 
> > > > > udp        0      0 0.0.0.0:40236 (http://0.0.0.0:40236/)               0.0.0.0:*                               850/avahi-daemon: r 
> > > > > udp        0      0 0.0.0.0:58882 (http://0.0.0.0:58882/)               0.0.0.0:*                               -                   
> > > > > udp        0      0 192.168.122.1:53 (http://192.168.122.1:53/)            0.0.0.0:*                               1300/dnsmasq        
> > > > > udp        0      0 0.0.0.0:67 (http://0.0.0.0:67/)                  0.0.0.0:*                               1300/dnsmasq        
> > > > > udp        0      0 0.0.0.0:111 (http://0.0.0.0:111/)                 0.0.0.0:*                               1010/rpcbind        
> > > > > udp        0      0 0.0.0.0:631 (http://0.0.0.0:631/)                 0.0.0.0:*                               1106/cupsd          
> > > > > udp        0      0 0.0.0.0:757 (http://0.0.0.0:757/)                 0.0.0.0:*                               1010/rpcbind        
> > > > > udp        0      0 0.0.0.0:47943 (http://0.0.0.0:47943/)               0.0.0.0:*                               1192/rpc.statd      
> > > > > udp        0      0 0.0.0.0:944 (http://0.0.0.0:944/)                 0.0.0.0:*                               1192/rpc.statd      
> > > > > udp        0      0 :::111                      :::*                                    1010/rpcbind        
> > > > > udp        0      0 :::757                      :::*                                    1010/rpcbind        
> > > > > udp        0      0 :::35635                    :::*                                    1192/rpc.statd      
> > > > > 
> > > > > -
> > > > > Sonny
> > > > > 
> > > > > 
> > > > > On Fri, May 4, 2012 at 10:36 AM, Dan Talayco <dtalayco at stanford.edu (mailto:dtalayco at stanford.edu)> wrote:
> > > > > > It looks like you have the OVS veth connections and the OFTest veth connections on the same end.   
> > > > > > 
> > > > > > 
> > > > > > On Thursday, May 3, 2012 at 9:21 PM, sonny sonny wrote:
> > > > > > 
> > > > > > > Hi Dan,
> > > > > > >  
> > > > > > > Thanks for your quick response.
> > > > > > >  
> > > > > > > first I want to confirm, is the port mapping is correct by below mentioned commands?
> > > > > > >  
> > > > > > > I am not using ctl script as oftest code I have downloaded from git was not having this file.
> > > > > > > but I am doing mapping manually.
> > > > > > >  
> > > > > > > some test are passing but as out of all modules, none is working in one go.
> > > > > > > I have to run every test case separately,when running module, "address is in use" error coming.
> > > > > > >  
> > > > > > > - Sonny
> > > > > > > 
> > > > > > > On Thu, May 3, 2012 at 11:52 PM, Dan Talayco <dtalayco at stanford.edu (mailto:dtalayco at stanford.edu)> wrote:
> > > > > > > > But I believe I've seen some kind of discovery packets coming out of OVS, right?  I was under the impression they even used the LLDP reserved address, or something close to it.  Maybe LLDP-like?  :) 
> > > > > > > > 
> > > > > > > > -Dan 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > On Thursday, May 3, 2012 at 10:25 AM, Ben Pfaff wrote:
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > > On Thu, May 03, 2012 at 10:08:39AM -0700, Dan Talayco wrote:
> > > > > > > > > > OVS like many switches send out LLDPs periodically.
> > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > No, OVS doesn't have any code for LLDP. 
> > > > > > > > > _______________________________________________
> > > > > > > > > openflow-discuss mailing list
> > > > > > > > > openflow-discuss at lists.stanford.edu (mailto:openflow-discuss at lists.stanford.edu)
> > > > > > > > > https://mailman.stanford.edu/mailman/listinfo/openflow-discuss
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > _______________________________________________
> > > > > > > > openflow-discuss mailing list
> > > > > > > > openflow-discuss at lists.stanford.edu (mailto:openflow-discuss at lists.stanford.edu)
> > > > > > > > https://mailman.stanford.edu/mailman/listinfo/openflow-discuss
> > > > > > > > 
> > > > > > > 
> > > > > > > _______________________________________________ 
> > > > > > > openflow-discuss mailing list
> > > > > > > openflow-discuss at lists.stanford.edu (mailto:openflow-discuss at lists.stanford.edu)
> > > > > > > https://mailman.stanford.edu/mailman/listinfo/openflow-discuss
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > 
> > > > > > 
> > > > > 
> > > > > _______________________________________________ 
> > > > > openflow-discuss mailing list
> > > > > openflow-discuss at lists.stanford.edu (mailto:openflow-discuss at lists.stanford.edu)
> > > > > https://mailman.stanford.edu/mailman/listinfo/openflow-discuss
> > > > > 
> > > > > 
> > > > > 
> > > > > Attachments: 
> > > > > - oft.log
> > > > > 
> > > > > 
> > > > > 
> > > > 
> > > > 
> > > 
> > 
> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/discuss/attachments/20120508/1b338d98/attachment-0001.htm>


More information about the discuss mailing list